home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-libs / alsa-lib-1.0.10 / alsa-lib-1.0.10.ebuild next >
Text File  |  2006-01-09  |  2KB  |  72 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.10.ebuild,v 1.8 2006/01/05 03:01:09 vapier Exp $
  4.  
  5. inherit eutils autotools
  6.  
  7. MY_P="${P/_rc/rc}"
  8. S="${WORKDIR}/${MY_P}"
  9.  
  10. DESCRIPTION="Advanced Linux Sound Architecture Library"
  11. HOMEPAGE="http://www.alsa-project.org/"
  12. SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
  13.  
  14. LICENSE="GPL-2 LGPL-2.1"
  15. SLOT="0"
  16.  
  17. KEYWORDS="alpha amd64 arm ~hppa ~ia64 ~mips ~ppc ppc64 ~sparc x86"
  18. IUSE="doc jack"
  19.  
  20. RDEPEND="virtual/alsa
  21.     >=media-sound/alsa-headers-${PV}"
  22. DEPEND="${RDEPEND}
  23.     doc? ( >=app-doc/doxygen-1.2.6 )"
  24.  
  25. PDEPEND="jack? ( =media-plugins/alsa-jack-${PV/_rc*/}* )"
  26.  
  27. src_unpack() {
  28.     unpack ${A}
  29.     cd ${S}
  30.     epatch "${FILESDIR}/${PN}-1.0.10_rc3-hardened.patch"
  31.     epatch "${FILESDIR}/${PN}-1.0.10_rc3-test.patch"
  32.     epatch "${FILESDIR}/${P}-test-ppc.patch"
  33.  
  34.     eautoreconf
  35. }
  36.  
  37. src_compile() {
  38.     # needed to avoid gcc looping internaly
  39.     use hppa && export CFLAGS="-O1 -pipe"
  40.  
  41.     econf \
  42.         --enable-static \
  43.         --enable-shared \
  44.         || die "configure failed"
  45.  
  46.     emake || die "make failed"
  47.  
  48.     if use doc; then
  49.         emake doc || die "failed to generate docs"
  50.     fi
  51. }
  52.  
  53. src_install() {
  54.     make DESTDIR="${D}" install || die "make install failed"
  55.  
  56.     dodoc ChangeLog TODO
  57.     use doc && dohtml -r doc/doxygen/html/*
  58. }
  59.  
  60. pkg_postinst() {
  61.     einfo "If you are using an emu10k1 based sound card, and you are upgrading"
  62.     einfo "from a version of alsalib <1.0.6, you will need to recompile packages"
  63.     einfo "that link against alsa-lib due to some ABI changes between 1.0.5 and"
  64.     einfo "1.0.6 unique to that hardware. You can do this by executing:"
  65.     einfo "revdep-rebuild --soname libasound.so.2"
  66.     einfo "See the following URL for more information:"
  67.     einfo "http://bugs.gentoo.org/show_bug.cgi?id=65347"
  68.     echo
  69.     ewarn "Please use media-sound/alsa-driver rather than in-kernel drivers as there"
  70.     ewarn "have been some problems recently with the in-kernel drivers.  See bug #87544."
  71. }
  72.